دیجی اسکریپت

ماژول‌های مورد نیاز PHP برای وردپرس که باید روی سرور نصب کنیم | دیجی اسکریپت

ماژول‌های مورد نیاز PHP برای وردپرس که باید روی سرور نصب کنیم

وردپرس با زبان PHP برنامه‌نویسی شده و قطعا برای اجرای صحیح روی php نیاز به ماژول‌هایی دارد. در این مقاله شما را با لیستی از ماژول‌های مورد نیاز PHP برای وردپرس آشنا خواهیم کرد.

 

سال‌ها است که PHP به عنوان یک زیر ساخت برای وردپرس استفاده می­شود. PHP با توسعه خود توانست همچنان پیشتاز در این رقابت باقی بماند. PHP با به‌روزرسانی و ارتقای خود ویژگی‌­ها و عملکردهای جدیدی را در اختیار کاربر قرار می­دهد. شاید در نگاه اول برخی از به‌روزرسانی­‌ها به ظاهر ساده و جزئی به نظر بیایند. اما کمک کرده تا PHP به یک زبان برنامه نویسی در حال پیشرفت و رقابتی تبدیل شود.

 

نسخه های قدیمی PHP آپدیت‌های امنیتی را دریافت نمی‌کنند. بنابراین اگر یک سایت مبتنی براین نسخه‌های قدیمی باشد، از امنیت خوبی برخوردار نیست. در نتیجه، انجمن توسعه دهندگان PHP به طور مداوم آن را برای رفع اشکال و آسیب پذیری‌های امنیتی به‌روزرسانی می‌کنند. بنابراین، استفاده از نسخه­‌های جدید PHP موجب امنیت، سرعت و عملکرد بهینه سایت می­شود. از اواسط سال ۲۰۱۷، نیز وردپرس رسما از مشتریان خود خواست که از PHP 7.2 یا نسخه های بالاتر استفاده کنند.

ماژول‌های مورد نیاز PHP برای وردپرس که باید روی سرور نصب کنیم

ماژول‌های مورد نیاز PHP برای وردپرس

بنابراین به منظور راه اندازی سریع و باکیفیت یک سرور برای وردپرس لازم است، ماژول‌های جدیدی از PHP نصب شود تا وردپرس نیز بهترین عملکرد را داشته باشد. با این حال، برای نصب ماژول های PHP لازم است اول بدانیم سرور اصلی مورد استفاده ما چیست. سپس براین اساس ممکن است ماژول مورد استفاده، در هر مورد متفاوت باشد. با این حال، نصب افزونه‌های زیر برای PHP 7.2 و بالاتر توصیه می­شود:

cmath -- قابل استفاده برای عملیات ریاضی
cli -- قابل استفاده توسط اسکریپت‌های شل
common -- یکی از ماژول‌های اصلی پی اچ پی
curl -- قابل استفاده برای درخواست‌های وردپرس
dom -- قابل استفاده در ماژول ساخت نقشه سایت
fileinfo -- برای دریافت اطلاعات فایل آپلودی در وردپرس
filter -- برای فیلتر‌کردن ورودی‌های کاربر
hash -- برای هش کردن اطلاعات سایت
fpm -- برای افزایش کیفیت و کارایی پی اچ پی
gd -- برای کار روی تصاویر و تغییر سایز تصاویر
imagick -- اگر ماژول بالا را نصب نکرده‌اید برای کار روی تصاویر و تغییر سایز تصاویر این ماژول را نصب کنید
iconv -- برای تبدیل کاراکتر‌های متن در وردپرس
json -- مدیریت اپلیکیشن‌های موبایل و اتصالات وردپرس
libsodium -- برای درک بهتر کاراکتر‌های فارسی و سایر زبان‌ها
mysql -- اتصال وردپرس و دیتابیس
openssl -- مدیریت درخواست‌های اس اس ال
pcre
opcache -- کش کردن فایل‌های پی اچ پی (همانطور که در دوره افزایش سرعت توضیح دادم)
readline -- توابع مربوط به کامند لاین
xml -- ساخت نقشه سایت و فایل‌های ایکس ام ال
zip -- ساخت و مدیریت فایل‌های زیپ توسط وردپرس
gettext -- برای دریافت اطلاعات فایل ترجمه
date -- برای دریافت اطلاعات تاریخ و زمان
soap -- اگر سایت شما ایرانی هست حتما برای اتصال به درگاه‌های پرداخت ایرانی نیاز دارید. اگر نه نیازی نیست. فقط درگاه‌های ایرانی از این سیستم قدیمی و منسوخ استفاده می‌کنند. :|

ماژول‌های پیشنهادی سایت وردپرس

البته جدا از ماژول‌های مورد نیاز که ما در قسمت بالا به شما معرفی کردیم. در سایت WordPress.org نیز یک سری ماژول‌ها برای PHP معرفی شده‌اند. اما این ماژول‌ها در واقع مناسب PHP 5.6 است. به همین دلیل استفاده از این ماژول‌ها توصیه نمی‌شود. اگر قصد دارید روی لوکال هاست یا سرور اصلی خود ماژول‌های مورد نیاز وردپرس را روی PHP نصب کنید، به لیست بالا دقت ویژه‌ای داشته باشید.

موفق باشید.

نوشته ماژول‌های مورد نیاز PHP برای وردپرس که باید روی سرور نصب کنیم اولین بار در بیست اسکریپت. پدیدار شد.



لینک منبع مطلب

ارسال دیدگاه جدید

به نکات زیر توجه کنید

  • نظرات شما پس از بررسی و تایید نمایش داده می شود.
  • لطفا نظرات خود را فقط در مورد مطلب بالا ارسال کنید.